Querious

Basic Usage

Main Views

The “Connection Window” in Querious has four main views which can be selected in the window’s toolbar.

Image of the four main views in the toolbar

The Content and Structure views allow you to view the content of or edit the structure of databases, tables, views, functions, procedures, events, and triggers. For instance, you would use the Content view to view the data in a table, and you would use the Structure view to add or remove columns from that table.

The Query view is for executing one or more “hand-written” SQL queries, and viewing the results of those queries.

The Server view contains several subviews to monitor, configure, and analyze the MySQL server’s status and behavior.


Multiple Tabs

Each connection window can contain multiple tabs, just like the Safari web browser. Each tab is independent and can be connected to the same or different MySQL servers. Tabs can be dragged between windows or torn out to create a new window.

To create a new tab connected to the same server as the curent tab, use the File ➞ New Connected Tab menu item. You can also right-click on any table, view, database, etc in the sidebar on the left side of the Content and Structure views, and select Open in New Tab.


Go To…

The View ➞ Go To… menu item displays a search field in a floating window. In this search field you can type the name of a database, table, view, etc to quickly select and display it.

Go To window

The search field also accepts any partial matches, and also understands the “database.object” naming scheme from MySQL to narrow results down to only that given database. Notice that the results in the screenshot below are limited to the “sakila” database based on the partial match of “sak”.

Go To search results


Querious maintains a history of each view and selection you use to so that you can use browser-like forward/backward navigation to quickly move between locations. See the Go Forward and Go Backward menu items in the View menu.

Forward and Backward Navigation